Loading...
 

FAQ



Here are the most frequent questions that have arised concerning MetaTrader in combination with the messaging modules and the MetaQoutes Language (MQL).

Where can I find the API doc for each module?

For each module there are correspoinding API documentations you can find in the source code repo. Walk down the directory tree beginning at the API directory. There are docs for each version of the module that will help you get along.

Where can I find usage examples for each module?

For each module there are correspoinding MQL examples you can find in the source code repo. Walk down the directory tree beginning at the MQL5 directory. There are "Expert Advisors" and "Include" files for each version of the module that will help you get along.

Why do I get 'operation was cancelled' error?

The most obvios solution is to set the timeout for the requests of your module to a larger amount of seconds. The reason then is that either your network is a bottleneck (low bandwith, large round trip times) or your host is not able to process the requests within the needed time. Use the Initialize or SetRequestTimeout function to vary the timeout. 

The less obvios solution is, that the host could not be reached. Check your network for proxy settings and firewall settings. In the case of Telegram you might be settled in a country (like Russia) where direct access to the API (api.telegram.org) is not permitted. Then you might intentionally try proxies. See proxy settings for MetaTrader and your OS for more information. If SOCKS access to the hostnames you need is permitted too then a VPN/TOR connection or using VPS settled in another country will help.

Is MQL4/MT4 supported?

No it is not. MetaQuotes announced that they will not support this platform any longer and so do I with MMM. See this Post for more information. Despites you might be lucky and the software will run though. Please don't ask for support if it does not. 

Side note for Telegram fans: Version 1.3 of the telegram module will work with MT4. But there is no support for that version.